首页 » PHP » 正文

记录一次composer排错问题卡在 Updating dependencies (including require-dev)

发表于: PHP,JS,Golang,Shopify学习交流博客 – 咪啪咪啪的小木屋 · 2021-4-27 ·  663 views  ·  0 replies 

今天遇到一个问题,命令行卡在Updating dependencies (including require-dev),然后过了一会直接提示killed

遇到这种问题,网上很多教程都是建议换阿里源

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/

但是对于我这没生效,这时候就需要排查下其他问题,输入下面命令

composer diagnose

检测下是否有没有报错,我这提示有几个函数被禁止了,按照提示去php.ini把他们打开

紧接着继续composer install,发现还是不行啊
然后想了想,升级下composer吧

composer self-update

可能会提示让直接使用

composer self-update --2

升级完版本之后,再试下composer install
如果提示

Problem 1
    - Root composer.json requires laravel/lumen-framework, it could not be found in any version, there may be a typo in the package name.

那么大概率是源的问题,及时我们配置了全局源,这时候也要看下目录下的composer.json

 "repositories": {
        "packagist": {
            "type": "composer",
            "url": "https://mirrors.aliyun.com/composer/"
        }
    }

这里也要修改下,另外composer lock文件也要注意
都改完之后,发现没问题了
有的时候会提示版本问题,这时候我们可以这样

composer install --prefer-dist --ignore-platform-reqs

其中

--ignore-platform-reqs 

上面这条命令是忽略版本

--prefer-dist

上面这条命令是

Composer的 –prefer-dist参数
最近一年以来的Composer会自动存档你下载的dist包。默认设置下,dist包用于加了tag的版本,例如"symfony/symfony": "v2.1.4",或者是通配符或版本区间,"2.1.*"或">=2.2、<2.3-dev"。
dist包也可以用于诸如dev-master之类的分支,Github允许你下载某个git引用的压缩包。为了强制使用压缩包,而不是克隆源代码,你可以使用install和update的–prefer-dist选项。
即使用–prefer-dist参数,为了强制使用压缩包,而不是克隆源代码。
来源: https://www.cnblogs.com/xi-jie/articles/10695622.html

«上一篇: :下一篇»

0 thoughts on “记录一次composer排错问题卡在 Updating dependencies (including require-dev)”

  1. 还没有任何评论,你来说两句吧

Leave a reply